Xshell|Xftp 强制升级,不升不给用?

小助手读文章 00:00 / 00:00

前两天开 Xshell 连服务器时突然弹了个窗:

要继续使用此程序,您必须应用最新的更新或使用新版本。

我......

作为用户而言,应该时最讨厌这种绑架行为了,像某卫士强制锁定浏览器首页、明明只下载了一个软件结果安装后看到全家桶、装个杀毒软件送了一堆病毒......

扯远了,对于 Xshell 不升级不能用的情况,原本我是想,应该是企业基于安全性、性能提升等考虑,希望用户升级,但似乎时想多了,因为只有某个特定版本才会出现这提示......

那么有没有办法不升级继续使用呢?

毕竟用习惯了,还是便携版的,这个问题难不倒广大网友,这不,方案来了:

方案一、改系统日期

方法

将系统时间设置到 2018/12/25 前,软件即可正常使用,打开后时间可以调回来。

优势

简单,快捷

缺陷

每次打开都要调时间,麻烦,而且一不注意时间没调回来,还以为天天是圣诞节。

方案二、改软件逻辑

方法

利用 UltraEdit、C32asm 等可以编辑 16 进制的编辑软件,编辑程序安装目录下的 nslicense.dll,搜索 7F0C81F98033E1010F8680,改为 7F0C81F98033E101E981007F0C81F98033E1010F8380

优势

方便,一劳永逸

缺陷


参考文章

1、《Xshell无法启动:要继续使用此程序,您必须应用最新的更新或使用新版本


ArmxMod for Typecho
个性化、自适应、功能强大的响应式主题

推广

 继续浏览关于 sshxshellxftp 的文章

 本文最后更新于 2018/12/29 08:00:00,可能因经年累月而与现状有所差异

 引用转载请注明:VirCloud's Blog > 运维 > Xshell|Xftp 强制升级,不升不给用?

精选评论